Nikon Emulator

All things embedded.
*NO FEATURE REQUESTS*

Re: Nikon Emulator [was: Fujitsu Fr Emulator]

Postby 4cc3ss » Sun Nov 24, 2013 1:34 am

I guess you have to look for solutions when running a 286DX, every bit of processing power counts.
Good job coderat. :clap:

Best regards,
4cc3ss
4cc3ss
 
Posts: 855
Joined: Fri Mar 23, 2012 11:38 am
Location: Uk
Been thanked: 216 times

Re: Nikon Emulator [was: Fujitsu Fr Emulator]

Postby coderat » Thu Dec 05, 2013 8:18 pm

coderat
Core Developer
 
Posts: 2283
Joined: Fri Apr 26, 2013 10:21 am
Been thanked: 450 times

Re: Nikon Emulator [was: Fujitsu Fr Emulator]

Postby 4cc3ss » Fri Dec 06, 2013 10:20 am

Good job coderat. :clap:

Best regards,
4cc3ss
4cc3ss
 
Posts: 855
Joined: Fri Mar 23, 2012 11:38 am
Location: Uk
Been thanked: 216 times

Re: Nikon Emulator [was: Fujitsu Fr Emulator]

Postby Vicne » Fri Dec 06, 2013 2:09 pm

Vicne
Core Developer
 
Posts: 1730
Joined: Tue Nov 29, 2011 2:30 pm
Been thanked: 167 times

Re: Nikon Emulator [was: Fujitsu Fr Emulator]

Postby coderat » Fri Dec 06, 2013 2:19 pm

coderat
Core Developer
 
Posts: 2283
Joined: Fri Apr 26, 2013 10:21 am
Been thanked: 450 times

Re: Nikon Emulator [was: Fujitsu Fr Emulator]

Postby leegong » Mon Dec 09, 2013 5:44 am

@coderat,
Good work!
I usually search for specific RTOS sys call with UltraEdit , just find a bug in disassembler ,
input parameters for RTOS sys_call seem wrong somewhere in ASM , the following code is copied from ASM file .
BFC15C5C li $a1, 0x8000
BFC15C60 jal $v0=sys_wai_flg_00(flag_id=0x1, wai_pattern=0x8000, wait_flag_mode_or_if_set=0x1, p_return_flag_pattern=$a3)
BFC15C64 li $a0, 0x0D
BFC15C66 li $a1, 0x01
BFC15C68 jal $v0=sys_sta_tsk_00(tsk_id=0xd, tsk_param=0x1)
BFC15C6C li $a0, 0x09
leegong
Core Developer
 
Posts: 2143
Joined: Mon Mar 19, 2012 12:21 am
Location: Hangzhou , China
Been thanked: 553 times

Re: Nikon Emulator [was: Fujitsu Fr Emulator]

Postby coderat » Mon Dec 09, 2013 6:13 am

coderat
Core Developer
 
Posts: 2283
Joined: Fri Apr 26, 2013 10:21 am
Been thanked: 450 times

Re: Nikon Emulator [was: Fujitsu Fr Emulator]

Postby leegong » Mon Dec 09, 2013 6:45 am

leegong
Core Developer
 
Posts: 2143
Joined: Mon Mar 19, 2012 12:21 am
Location: Hangzhou , China
Been thanked: 553 times

Re: Nikon Emulator [was: Fujitsu Fr Emulator]

Postby coderat » Mon Dec 09, 2013 6:51 am

coderat
Core Developer
 
Posts: 2283
Joined: Fri Apr 26, 2013 10:21 am
Been thanked: 450 times

Re: Nikon Emulator [was: Fujitsu Fr Emulator]

Postby leegong » Mon Dec 09, 2013 7:37 am

leegong
Core Developer
 
Posts: 2143
Joined: Mon Mar 19, 2012 12:21 am
Location: Hangzhou , China
Been thanked: 553 times

PreviousNext

Return to Firmware

Who is online

Users browsing this forum: No registered users and 10 guests